Project

Development

Products

DataNucleus AccessPlatform provides persistence and retrieval of data to a range of datastores using a range of APIs, with a range of query languages. It is provided under the Apache 2 license, and supports persistence to the following datastores : RDBMS, Neo4j, LDAP, Excel (XLS/OOXML), XML, NeoDatis, JSON, ODF, HBase, Amazon S3, GoogleStorage, MongoDB, Cassandra, [db4o]

Version Latest Status APIs JRE Released Support Documentation Release Notes
5.0 (Schrodinger) 5.0.0.M4 Developed JDO3.2, JPA2.1, REST 1.8+ Free, Commercial Online | Download | PDF HTML
4.2 (Planck) 4.2.5 Developed JDO3.2, JPA2.1, REST 1.7+ Oct/2015 Free, Commercial Online | Download | PDF HTML
4.1 (Chadwick) 4.1.10 Developed JDO3.1, JPA2.1, REST 1.7+ May/2015 Free, Commercial Online | Download | PDF HTML
4.0 (Einstein) 4.0.7 Retired JDO3.1, JPA2.1, REST 1.7+ Jun/2014 Commercial Online | Download | PDF HTML
3.3 (Galileo) 3.3.8 Retired JDO3.1, JPA2.1, REST 1.6+ Jun/2013 Commercial Online | Download | PDF HTML
3.2 (Copernicus) 3.2.9 Retired JDO3.1, JPA2.0, REST 1.6+ Mar/2013 Commercial Online | Download | PDF HTML
3.1 (Kepler) 3.1.5 Retired JDO3.1, JPA2.0, REST 1.6+ Jul/2012 None Online | Download HTML
3.0 (Newton) 3.0.10 Retired JDO3.0, JPA2.0, REST 1.5+ Aug/2011 None Online | Download HTML
2.2 (Geiger) 2.2.3 Retired JDO3.0, JPA2.0, REST 1.5+ Dec/2010 None Download | PDF HTML
2.1 (Thomson) 2.1.4 Retired JDO3.0, JPA2.0, REST 1.5+ Jun/2010 None Download | PDF HTML
2.0 (Bohr) 2.0.5 Retired JDO2.2, JPA1.0, REST 1.5+ Jan/2010 None Download | PDF HTML
1.1 (Rutherford) 1.1.6 Retired JDO2.2, JPA1.0, REST 1.5+ Feb/2009 None Download | PDF HTML
1.0 (Faraday) 1.0.5 Retired JDO2.2, JPA1.0, REST 1.3+ Sep/2008 None Download | PDF HTML

Plugins

DataNucleus products are built from a series of plugins. Each plugin is an OSGi bundle. Each plugin provides a level of functionality to the overall DataNucleus platform and the plugins can be individually downloaded if required rather than waiting for the next full release of a product, but if doing that always be careful of cross-compatibility of versions of plugins.