DataNucleus JIRA is now in read-only mode. Raise any new issues in GitHub against the plugin that it applies to. DataNucleus JIRA will remain for the foreseeable future but will eventually be discontinued
Issue Details (XML | Word | Printable)

Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Unassigned
Reporter: fabio.boldrini
Votes: 0
Watchers: 0

If you were logged in you would be able to see more operations.
DataNucleus Tools : Eclipse plugin

Version 3.0.2 seem compiled with java 7

Created: 15/Apr/13 01:07 PM   Updated: 15/May/13 09:32 AM   Resolved: 15/Apr/13 03:32 PM
Component/s: None
Affects Version/s: 3.0.2
Fix Version/s: 3.0.4

Environment: eclipse juno on OSX 10.6.8

 Description  « Hide
The plugin version 3.0.2 seem compiled with java 7, and with eclipse running on java 6 it generate error on configuration and enhancer execution.

I reverted to 3.0.1 and it work lawlessly.

On this version of OSX i cant use java7 (except the OpenJDK)

Sort Order: Ascending order - Click to sort in descending order
Andy Jefferson added a comment - 15/Apr/13 01:25 PM
Try 3.0.3 and report back whether it works or not (Eclipse is exceptionally crap at allowing a developer to build against one JDK whilst using another, and since I use JDK1.7 then it must have done that regardless of the code compataibility options - 3.0.3 is the same code rebuilt whilst running with JDK1.6)

fabio.boldrini added a comment - 15/Apr/13 01:59 PM
3.0.3 same problem

Andy Jefferson added a comment - 15/Apr/13 02:34 PM
so define "the problem" ... like what is the exception/error ? Guesswork is futile

fabio.boldrini added a comment - 15/Apr/13 02:56 PM
When i select the project properties and open the DataNucleus property i see the sub menu Enhancer and SchemaTool, but if i select them, i get the .51 version problem (.51 is java versione for java 7).

When i try to execute DataNucleus->Run Enhancer Tool i get an error (kinda "unable to run", i dont remember it exactly) without other details, but i guess is related to the same problem.

If u dont like guesswork try to run eclipse with java6 and the plugin installed

Andy Jefferson added a comment - 15/Apr/13 03:32 PM
3.0.4 works for me.

For future reference we expect complete problem reports so it doesn't waste *our* spare time when a user has all information available there but doesn't bother posting it. The only way that will change is if people offer their time to this project.