DataNucleus JIRA is now in read-only mode. Raise any new issues in GitHub against the plugin that it applies to. DataNucleus JIRA will remain for the foreseeable future but will eventually be discontinued
Issue Details (XML | Word | Printable)

Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Minor Minor
Assignee: Unassigned
Reporter: Andy Jefferson
Votes: 0
Watchers: 0

If you were logged in you would be able to see more operations.
DataNucleus Tools : Eclipse plugin

PK class generation misses off hashCode() method, and sometimes also the field

Created: 10/Jun/14 05:16 PM   Updated: 17/Jun/14 05:50 PM   Resolved: 10/Jun/14 07:47 PM
Component/s: None
Affects Version/s: None
Fix Version/s: 4.0.0.release

Andy Jefferson added a comment - 10/Jun/14 07:47 PM
GitHub master adds the hashCode to the generated application PK class. Not able to reproduce the missing field ... maybe wasn't selected on the popup?

Andy Jefferson made changes - 10/Jun/14 07:47 PM
Field Original Value New Value
Status Open [ 1 ] Resolved [ 5 ]
Fix Version/s 4.0.0.release [ 12142 ]
Resolution Fixed [ 1 ]
Andy Jefferson made changes - 17/Jun/14 05:50 PM
Status Resolved [ 5 ] Closed [ 6 ]