Issue Details (XML | Word | Printable)

Key: NUCACCESS-106
Type: Improvement Improvement
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Andy Jefferson
Reporter: Andy Jefferson
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
DataNucleus AccessPlatform

Put OSGi importPackage version restrictions on javax.transaction

Created: 25/Oct/12 12:31 PM   Updated: 15/Nov/12 03:38 PM   Resolved: 25/Oct/12 12:37 PM
Component/s: None
Affects Version/s: None
Fix Version/s: 3.2.0.m1


 Description  « Hide
Having this means that people can just use datanucleus-core etc directly in OSGi and not worry about correct import of javax.transaction classes

Sort Order: Ascending order - Click to sort in descending order
Andy Jefferson added a comment - 25/Oct/12 12:37 PM
SVN trunk fixes this for core/api.jdo and removes the importPackage from all other plugins since they don't need it.