Issue Details (XML | Word | Printable)

Key: NUCACCESS-112
Type: Bug Bug
Status: Closed Closed
Resolution: Won't Fix
Priority: Testcase Required Testcase Required
Assignee: Unassigned
Reporter: Ramón
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
DataNucleus AccessPlatform

The enhancer (new and old) does not works with dynamically generated classes (from groovy).

Created: 11/Mar/13 06:35 PM   Updated: 16/May/13 11:39 AM   Resolved: 23/Apr/13 10:07 AM
Component/s: Software
Affects Version/s: 3.2.0.release
Fix Version/s: None

Environment: All environment

Severity: Development


 Description  « Hide
Since the pojo model class is created at run time (from groovy for example), it can't be passed to enhancer because the enhancer needs the class file accessible by URL. I can't found the way to write that created class into filesystem, to pass it to enhancer. Maybe it's a issue from asm library. If there are any manner to enhance a groovy class, please make any post about it. Thanks.

Best regards.


Andy Jefferson added a comment - 11/Mar/13 07:13 PM
No way of reproducing, and I don't use Groovy.

Andy Jefferson made changes - 11/Mar/13 07:13 PM
Field Original Value New Value
Priority Minor [ 4 ] Incomplete [ 6 ]
Andy Jefferson added a comment - 11/Mar/13 07:52 PM - edited
Would have thought that Groovy still uses Java class loading, hence use of javaagent ought to work (and there are links on the web of people doing the same with EclipseLink javaagent). When you've done that you could contribute a simple guide for how to use DataNucleus with Groovy.

Andy Jefferson added a comment - 23/Apr/13 10:07 AM
Can't do anything here since there is no specific problem, and the user should follow the recommendation of using javaagent to intercept runtime loading. Failing that it is for people to define where the problem is and propose a solution.

Andy Jefferson made changes - 23/Apr/13 10:07 AM
Status Open [ 1 ] Resolved [ 5 ]
Resolution Won't Fix [ 2 ]
Andy Jefferson made changes - 16/May/13 11:39 AM
Status Resolved [ 5 ] Closed [ 6 ]