Issue Details (XML | Word | Printable)

Key: NUCACCESS-81
Type: Bug Bug
Status: Closed Closed
Resolution: Cannot Reproduce
Priority: Minor Minor
Assignee: Unassigned
Reporter: Fiaz Hossain
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
DataNucleus AccessPlatform

@Transient fields created on embeddable classes show up as persistent on embedded class

Created: 27/Dec/10 07:53 AM   Updated: 27/Jan/11 07:51 PM   Resolved: 27/Dec/10 09:14 AM
Component/s: None
Affects Version/s: 2.2.0.release
Fix Version/s: None

File Attachments: 1. Zip Archive embeddable.zip (3 kB)

Environment: Linux

Datastore: HSQL
Severity: Development


 Description  « Hide
A field declared @Transient on an @Embeddable class A shows up as PERSISTENT on an embedded class B. The AbstractClassMetaData for the embeddable class A correctly shows that the transient field's persistence modifier is none. However, when this embeddable class A is embedded into class B the transient field of A shows up with persistence modifier PERSISTENT. Adding a test case to demonstrate the problem.

Fiaz Hossain added a comment - 27/Dec/10 07:56 AM
The attached zip file demonstrates the problem I reported. The last two log lines in from the main program shows the error -
Dec 26, 2010 10:25:49 PM org.datanucleus.test.Main main
INFO: ERROR: transient field shows up as persistent
Dec 26, 2010 10:25:54 PM org.datanucleus.test.Main main
INFO: ERROR: validated transient field properly declared in embeddable class

Fiaz Hossain made changes - 27/Dec/10 07:56 AM
Field Original Value New Value
Attachment embeddable.zip [ 11320 ]
Fiaz Hossain added a comment - 27/Dec/10 08:29 AM
I tested against 2.2.1-SNAPSHOT and the transient field is no longer included in the embedded class B's metadata. This fixes my complaint.

Andy Jefferson added a comment - 27/Dec/10 09:14 AM
Doesn't show up any error - no log entry is made for "ERROR". As said earlier, likely http://www.datanucleus.org/servlet/jira/browse/NUCCORE-619

Andy Jefferson made changes - 27/Dec/10 09:14 AM
Status Open [ 1 ] Resolved [ 5 ]
Resolution Cannot Reproduce [ 5 ]
Andy Jefferson made changes - 27/Jan/11 07:51 PM
Status Resolved [ 5 ] Closed [ 6 ]