DataNucleus JIRA is now in read-only mode. Raise any new issues in GitHub against the plugin that it applies to. DataNucleus JIRA will remain for the foreseeable future but will eventually be discontinued
Issue Details (XML | Word | Printable)

Key: NUCACCESS-87
Type: Bug Bug
Status: Closed Closed
Resolution: Won't Fix
Priority: Minor Minor
Assignee: Unassigned
Reporter: Guillaume Houdmon
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
DataNucleus AccessPlatform

Bundles 3.0.0.m2 requires core bundle version 3.0.0.m1

Created: 03/Mar/11 04:56 PM   Updated: 14/Jun/11 12:23 PM   Resolved: 07/Mar/11 05:40 PM
Component/s: None
Affects Version/s: 3.0.0.m2
Fix Version/s: None

Environment: OSGI

Severity: Development


 Description  « Hide
Wrong bundle-version into Require-Bundle directive of bundles "org.datanucleus.api.jdo", "org.datanucleus.api.jpa", "org.datanucleus.store.rdbms" (and maybe more).

They require "org.datanucleus" in version 3.0.0.m1 instead of 3.0.0.m2.

It should be more flexible to use not qualified version (3.0.0).

Sort Order: Ascending order - Click to sort in descending order
Andy Jefferson added a comment - 03/Mar/11 05:06 PM
The MANIFEST.MF (of api.jdo) clearly says
Require-Bundle: org.datanucleus;bundle-version="3.0.0.m1"

so it says that you can use that bundle with "3.0.0.m1" or later (at least that is my understanding of OSGi, as per http://static.springsource.org/s2-dmserver/2.0.x/getting-started/html/ch01.html ). So which part of that are you saying is invalid ?

Using unqualified would not make sense since if api.jdo requires a particular method in core then it needs that version of core or later.

Andy Jefferson added a comment - 03/Mar/11 05:07 PM
On a related point, if you intend on providing patches for such things, then also consider http://www.datanucleus.org/servlet/jira/browse/NUCACCESS-61 which still hasn't received input

Andy Jefferson added a comment - 07/Mar/11 05:40 PM
The report does not define what is the problem, so marking as wont fix. If you want to clarify what you actually mean then post a comment to this issue