Issue Details (XML | Word | Printable)

Key: NUCAPIJDO-52
Type: Bug Bug
Status: Closed Closed
Resolution: Cannot Reproduce
Priority: Testcase Required Testcase Required
Assignee: Unassigned
Reporter: Roland Beuker
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
DataNucleus API JDO

Duplicated field names are not loaded with defaultFetchGroup

Created: 26/Apr/13 12:47 PM   Updated: 10/Jun/13 08:46 AM   Resolved: 03/Jun/13 07:01 AM
Component/s: None
Affects Version/s: 3.2.0.release
Fix Version/s: None

File Attachments: 1. Zip Archive TestFiles.zip (12 kB)

Environment: Google App Engine

Forum Thread URL: DuplicatedFieldNamesNotLoaded
Datastore: MySQL
Severity: Development


 Description  « Hide
When using three classes, for example Relation, Employee and Project, Relation is used in both Employee and Project;

Relation;

@Persistent(defaultFetchGroup="true", mappedBy = "mRelation")
private Set<Employee> mEmployees;

@Persistent(defaultFetchGroup="true", mappedBy = "mRelation")
private Set<Project> mProjects;

Employee;

@Persistent(defaultFetchGroup="true")
private Relation mRelation;

Project;

@Persistent(defaultFetchGroup="true")
private Relation mRelation;


Due to the duplicated name mRelation in de mappedBy configuration from Relation these fields are not loaded in the defaultFetchGroup.

Andy Jefferson added a comment - 26/Apr/13 12:55 PM
All issues require a valid testcase as per the front page of JIRA and all DN docs. Additionally anything to do with other environments using 3rd party plugins should likely be reported to those projects not this.

Andy Jefferson made changes - 26/Apr/13 12:55 PM
Field Original Value New Value
Priority Major [ 3 ] Incomplete [ 6 ]
Roland Beuker added a comment - 26/Apr/13 01:42 PM
Testfiles.zip contains the classes Relation, Employee and Project. The test ProjectTest fails when loading field mRelation (line 83).

A work arround for this problem is renaming the field mRelation to mEmployeeRelation (for employee) and mProjectRelation (for Project)

Roland Beuker made changes - 26/Apr/13 01:42 PM
Attachment TestFiles.zip [ 11946 ]
Andy Jefferson added a comment - 26/Apr/13 02:26 PM
Testcase format is on the front page of JIRA, on the front page of DN docs.
http://www.datanucleus.org/project/problem_reporting.html

Andy Jefferson added a comment - 03/Jun/13 07:01 AM
No testcase, cannot reproduce

Andy Jefferson made changes - 03/Jun/13 07:01 AM
Status Open [ 1 ] Resolved [ 5 ]
Resolution Cannot Reproduce [ 5 ]
Andy Jefferson made changes - 10/Jun/13 08:46 AM
Status Resolved [ 5 ] Closed [ 6 ]