Issue Details (XML | Word | Printable)

Key: NUCCASSANDRA-23
Type: Task Task
Status: Closed Closed
Resolution: Fixed
Priority: Minor Minor
Assignee: Andy Jefferson
Reporter: Andy Jefferson
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
DataNucleus Store Cassandra

Add internal table/column definition, to avoid continual column naming lookups

Created: 24/Feb/14 10:25 AM   Updated: 13/Mar/14 08:03 PM   Resolved: 02/Mar/14 10:14 AM
Component/s: Code Structure
Affects Version/s: None
Fix Version/s: 4.0.0.m2


 Description  « Hide
Whenever we need to reference a column we generate the column name/cassandra type. We should build an internal model representation of a table with columns and cache this information (so whenever storeMgr.manageClass is called the first time it builds this info).

The code in datanucleus-core in package "org.datanucleus.store.schema.table" is not currently used by anything but was intended for this type of thing, so could be modified so that it will provide what is required for Cassandra (whilst keeping it as general as possible for other datastores that may use it in the future).

Andy Jefferson made changes - 24/Feb/14 11:25 AM
Field Original Value New Value
Description Whenever we need to reference a column we generate the column name/cassandra type. We should build an internal model representation of a table with columns and cache this information (so whenever storeMgr.manageClass is called the first time it builds this info) Whenever we need to reference a column we generate the column name/cassandra type. We should build an internal model representation of a table with columns and cache this information (so whenever storeMgr.manageClass is called the first time it builds this info).

The code in datanucleus-core in package "org.datanucleus.store.schema.table" is not currently used by anything but was intended for this type of thing, so could be modified so that it will provide what is required for Cassandra (whilst keeping it as general as possible for other datastores that may use it in the future).
Andy Jefferson added a comment - 02/Mar/14 10:14 AM
GitHub master cleans up the internals to use Table/Column

Andy Jefferson made changes - 02/Mar/14 10:14 AM
Status Open [ 1 ] Resolved [ 5 ]
Assignee Andy Jefferson [ andy ]
Fix Version/s 4.0.0.m2 [ 12111 ]
Resolution Fixed [ 1 ]
Andy Jefferson made changes - 13/Mar/14 08:03 PM
Status Resolved [ 5 ] Closed [ 6 ]