DataNucleus JIRA is now in read-only mode. Raise any new issues in GitHub against the plugin that it applies to. DataNucleus JIRA will remain for the foreseeable future but will eventually be discontinued
Issue Details (XML | Word | Printable)

Key: NUCCORE-1006
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Unassigned
Reporter: Andy Jefferson
Votes: 0
Watchers: 0

If you were logged in you would be able to see more operations.
DataNucleus Core

ObjectProvider pooling has problems when run multithreaded with large numbers of threads, so turn off pooling by default

Created: 06/Mar/13 03:47 AM   Updated: 08/Mar/13 02:57 PM   Resolved: 06/Mar/13 03:49 AM
Component/s: Code Structure, Persistence
Affects Version/s: 3.2.0.m3, 3.2.0.m4
Fix Version/s: 3.2.0.release

 Description  « Hide
Change the default to 0 maxSize of pool, meaning that there is no pooling enabled (until the problem is isolated)

Sort Order: Ascending order - Click to sort in descending order
Andy Jefferson added a comment - 06/Mar/13 03:49 AM
SVN trunk changes this to no pooling