Issue Details (XML | Word | Printable)

Key: NUCCORE-1090
Type: Bug Bug
Status: Closed Closed
Resolution: Won't Fix
Priority: Major Major
Assignee: Unassigned
Reporter: Stijn Slaets
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
DataNucleus Core

Datanucleus core has OSGi package dependencies on javax.jdo version "3.0.0" but the provided JDO API jar exports version "3.1.0.rc1"

Created: 11/Dec/13 10:54 AM   Updated: 17/Dec/13 08:19 AM   Resolved: 11/Dec/13 12:10 PM
Component/s: None
Affects Version/s: 3.2.10
Fix Version/s: None


 Description  « Hide
The jdo-api-3.1-rc1.jar file in the full-deps zip package of 3.3.5 exports its packages as version 3.1.0.rc1. This is not compatible with the package import statements of the MANIFEST of datanucleus core which expects a version of 3.0.0.
A solution might be to change the package import of the core MANIFEST to "[3.0.0,4.0.0)" this will accept all 3.x.x API jars (I'm assuming JDO is backwards compatible in its minor releases).

Andy Jefferson added a comment - 11/Dec/13 11:01 AM
Errm, no. datanucleus-core has version="3.0.0" which means [3.0.0, infinity)

Andy Jefferson added a comment - 11/Dec/13 12:10 PM
I see no "problem"

Andy Jefferson made changes - 11/Dec/13 12:10 PM
Field Original Value New Value
Status Open [ 1 ] Resolved [ 5 ]
Resolution Won't Fix [ 2 ]
Andy Jefferson made changes - 17/Dec/13 08:19 AM
Status Resolved [ 5 ] Closed [ 6 ]