Issue Details (XML | Word | Printable)

Key: NUCCORE-1221
Type: Task Task
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Unassigned
Reporter: Andy Jefferson
Votes: 0
Watchers: 0

If you were logged in you would be able to see more operations.
DataNucleus Core

NamingFactory getIndexName() methods should be renamed to getConstraintName() so we can use for unique constraint and FK constraint also

Created: 30/May/14 10:29 AM   Updated: 03/Jun/14 04:10 PM   Resolved: 30/May/14 11:05 AM
Component/s: Code Structure, Schema
Affects Version/s: None
Fix Version/s: 4.0.0.release

Sort Order: Ascending order - Click to sort in descending order
Andy Jefferson added a comment - 30/May/14 11:05 AM
GitHub master now generalises these methods to be usable for all constraints