Issue Details (XML | Word | Printable)

Key: NUCCORE-370
Type: Task Task
Status: Closed Closed
Resolution: Won't Fix
Priority: Major Major
Assignee: Unassigned
Reporter: Gregory Kick
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
DataNucleus Core

Sync the Maven Repository with Central

Created: 26/Aug/09 09:56 PM   Updated: 11/Sep/09 08:40 AM   Resolved: 27/Aug/09 04:04 AM
Component/s: None
Affects Version/s: 1.1.2, 1.1.3, 1.1.4, 1.1.5, 2.0.0.m1
Fix Version/s: None


 Description  « Hide
Datanucleus versions greater than 1.1.1 aren't available in the central data repository. Since artifacts in the central repository can't depend on external repositories [1], Google App Engine cannot be deployed because it depends on versions that aren't available. Please arrange for the datanucleus repository to sync with the central repository so that artifacts that depend on new versions can be deployed.

[1] http://maven.apache.org/guides/mini/guide-central-repository-upload.html

Sort Order: Ascending order - Click to sort in descending order
Andy Jefferson added a comment - 27/Aug/09 04:04 AM - edited
DataNucleus has its own M2 repo, and people can easily put that in their pom.xml. The server holding our artifacts is not under direct control so no immediate way of knowing if rsync is accessible or not (I left it as a question to the owner of the server). Also, unlike Google, we have limited manpower so are not taking on extra non-value-added work.