Issue Details (XML | Word | Printable)

Key: NUCCORE-771
Type: Bug Bug
Status: Closed Closed
Resolution: Cannot Reproduce
Priority: Major Major
Assignee: Unassigned
Reporter: Jan
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
DataNucleus Core

InheritanceStrategy.SUPERCLASS_TABLE and PersistenceManager#getObjectById

Created: 10/Oct/11 03:13 PM   Updated: 07/Nov/11 02:57 PM   Resolved: 10/Oct/11 05:44 PM
Component/s: None
Affects Version/s: 2.2.0.m1
Fix Version/s: None

File Attachments: 1. Zip Archive dn-testcase.zip (4 kB)


Forum Thread URL: http://www.datanucleus.org/servlet/forum/viewthread_thread,6869
Datastore: HSQL


 Description  « Hide
As described in http://www.datanucleus.org/servlet/forum/viewthread_thread,6869:

Having two classes ClassA and ClassB with inheritencestrategy = superclass, and I ask

pm.getObjectById(ClassB.class, Long.valueOf(7));

but instance '7' is of type ClassA, I don't get a proper exception. Testcase attached.

Jan added a comment - 10/Oct/11 03:13 PM
testcase

Jan made changes - 10/Oct/11 03:13 PM
Field Original Value New Value
Attachment dn-testcase.zip [ 11511 ]
Andy Jefferson added a comment - 10/Oct/11 03:37 PM
Works for me, but them I'm using recent and you're using something of 1yr ago. Suggest you debug it, or use a recent version

Jan added a comment - 10/Oct/11 03:56 PM
Could you be so kind and try it with the version I defined in the pom?

Andy Jefferson added a comment - 10/Oct/11 04:01 PM
Why should I use 2.2.0.m1? it's no longer supported


Andy Jefferson made changes - 10/Oct/11 05:44 PM
Status Open [ 1 ] Resolved [ 5 ]
Resolution Cannot Reproduce [ 5 ]
Jan added a comment - 11/Oct/11 06:42 PM
No offence Andy, you do great work here, but it would have been nice to know that you're not going to run the test-case against 2.x before you asked me to create one.

Andy Jefferson added a comment - 11/Oct/11 07:16 PM
Jan, no offence taken.
The docs state very clearly what version(s) are maintained/supported ... free and commercial, http://www.datanucleus.org/products/accessplatform.html
The forum README says to use nightly builds. The resource of this project is such that I will typically be working on latest code only (except during the phase of starting a new major release, when I'd maintain the previous for limited time).
Consequently it ought to have been easily concludable that I would run any testcase on the version I am maintaining (only), and I did just that. Needless to say that other people could offer their time to maintain old versions.

Obviously you could go through the same process with Hibernate (with their 20+ devs) and you won't even get it run on any version, to add to the 2500+ issues :-)

Andy Jefferson made changes - 07/Nov/11 02:57 PM
Status Resolved [ 5 ] Closed [ 6 ]