Issue Details (XML | Word | Printable)

Key: NUCCORE-831
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Unassigned
Reporter: Rick Vestal
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
DataNucleus Core

javax.xml.parsers should be imported in Import-Package of META-INF/MANIFEST.MF

Created: 30/Mar/12 11:39 PM   Updated: 06/Apr/12 05:53 PM   Resolved: 31/Mar/12 12:13 PM
Component/s: None
Affects Version/s: None
Fix Version/s: 3.1.0.m2

Environment: felix (karaf)


 Description  « Hide
When using datanucleus in karaf, the javax.xml.parsers classes can not be found. By adding the entry:

javax.xml.parsers;resolution:=optional,

to the META-INF/MANIFEST.MF file of the datanucleus core jar, the issue is taken care of.

Andy Jefferson added a comment - 31/Mar/12 12:13 PM
SVN trunk has this. thx

Andy Jefferson made changes - 31/Mar/12 12:13 PM
Field Original Value New Value
Status Open [ 1 ] Resolved [ 5 ]
Fix Version/s 3.1.0.m2 [ 11506 ]
Resolution Fixed [ 1 ]
Andy Jefferson made changes - 06/Apr/12 05:53 PM
Status Resolved [ 5 ] Closed [ 6 ]