Issue Details (XML | Word | Printable)

Key: NUCENHANCER-45
Type: Improvement Improvement
Status: Closed Closed
Resolution: Cannot Reproduce
Priority: Testcase Required Testcase Required
Assignee: Unassigned
Reporter: Eduardo Ramírez
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
DataNucleus Enhancer (ARCHIVED)

FindBugs warnings on PersistenceCapable.jdoCopyKeyFieldsFromObjectId method.

Created: 05/Oct/09 04:25 PM   Updated: 01/Apr/11 03:27 PM   Resolved: 24/Feb/11 05:25 PM
Component/s: None
Affects Version/s: None
Fix Version/s: None

Environment:
Debian Linux Sid x86-64
Java 1.6
Eclipse 3.5
Google App Engine Plugin 1.1.1.v200909221731

Datastore: Other
Severity: Development


 Description  « Hide
After JDO enhancer adds the methods to an @Entity, FindBugs reports the
following warning:

Method
net.frenopatico.kynes.searchr.models.Message.jdoCopyKeyFieldsFromObjectId(PersistenceCapable$ObjectIdFieldConsumer,
Object) invokes inefficient new Long(long) constructor; use
Long.valueOf(long) instead.


Andy Jefferson added a comment - 07/Oct/09 11:09 AM - edited
So provide a patch that fixes it. While doing so you can provide the Java file before, and the decompiled java file after so there is a reference for your comments

Andy Jefferson added a comment - 20/Nov/09 12:27 PM
No test class that demonstrates this, so will not be touched until the report is complete

Andy Jefferson made changes - 20/Nov/09 12:27 PM
Field Original Value New Value
Priority Trivial [ 5 ] Incomplete [ 6 ]
Andy Jefferson added a comment - 24/Feb/11 05:25 PM
Nothing to do without an example of the class (its PK fields) and the generated enhanced class

Andy Jefferson made changes - 24/Feb/11 05:25 PM
Status Open [ 1 ] Resolved [ 5 ]
Resolution Cannot Reproduce [ 5 ]
Andy Jefferson made changes - 01/Apr/11 03:27 PM
Status Resolved [ 5 ] Closed [ 6 ]