DataNucleus JIRA is now in read-only mode. Raise any new issues in GitHub against the plugin that it applies to. DataNucleus JIRA will remain for the foreseeable future but will eventually be discontinued
Issue Details (XML | Word | Printable)

Type: Improvement Improvement
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Unassigned
Reporter: Simon Kelly
Votes: 0
Watchers: 0

If you were logged in you would be able to see more operations.
DataNucleus Store HBase

Make use of Table pool when fetching tables

Created: 09/Mar/12 12:24 PM   Updated: 26/Oct/12 05:18 PM   Resolved: 07/Oct/12 11:38 AM
Component/s: Persistence, Queries
Affects Version/s: 3.0.6
Fix Version/s: 3.1.2

File Attachments: 1. Text File NUCHBASE-68.patch (4 kB)
2. Text File NUCHBASE-68_3.0.6.patch (5 kB)

Datastore: HBase

 Description  « Hide
Despite the pooling of HbaseConnections every time an instance of Htable is created a new connection is opened. To prevent the HTablePool class should be used to pool the tables.

Andy Jefferson added a comment - 09/Mar/12 12:38 PM
Why not attach a patch that does just that?

Simon Kelly made changes - 09/Mar/12 03:33 PM
Field Original Value New Value
Attachment NUCHBASE-68.patch [ 11605 ]
Simon Kelly added a comment - 09/Mar/12 03:41 PM
Patch for version 3.0.6

Simon Kelly made changes - 09/Mar/12 03:41 PM
Attachment NUCHBASE-68_3.0.6.patch [ 11606 ]
Simon Kelly added a comment - 09/Mar/12 04:18 PM
Turns out the new connections I was seeing were being caused by having


I still think a TablePool is good though.

Andy Jefferson added a comment - 07/Oct/12 11:38 AM
SVN trunk has this now, thx

Andy Jefferson made changes - 07/Oct/12 11:38 AM
Status Open [ 1 ] Resolved [ 5 ]
Fix Version/s 3.1.2 [ 11730 ]
Resolution Fixed [ 1 ]
Andy Jefferson made changes - 26/Oct/12 05:18 PM
Status Resolved [ 5 ] Closed [ 6 ]