Issue Details (XML | Word | Printable)

Key: NUCJDOQUERY-12
Type: Bug Bug
Status: Closed Closed
Resolution: Cannot Reproduce
Priority: Testcase Required Testcase Required
Assignee: Unassigned
Reporter: Stephane Passignat
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
DataNucleus JDO Query Processor

Build Hangling

Created: 26/Aug/11 02:34 PM   Updated: 09/Aug/12 09:56 AM   Resolved: 06/Jul/12 09:43 AM
Component/s: None
Affects Version/s: 3.0.0.release
Fix Version/s: None

Severity: Test/Acceptance


 Description  « Hide
The build hangling in JDOQueryProcessor.
Thread dump when using intellij Idea is bellow, with Ant it seems to work. Looks similar to the problem I had in the past when I tried to use the annotation porcessor to enhance the classes.

java.lang.Thread.State: RUNNABLE
at java.io.FileOutputStream.writeBytes(Native Method)
at java.io.FileOutputStream.write(FileOutputStream.java:260)
at java.io.BufferedOutputStream.flushBuffer(BufferedOutputStream.java:65)
at java.io.BufferedOutputStream.flush(BufferedOutputStream.java:123)
- locked <0x0000000023fb10c8> (a java.io.BufferedOutputStream)
at java.io.PrintStream.write(PrintStream.java:432)
- locked <0x0000000023fb10f0> (a java.io.PrintStream)
at sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:202)
at sun.nio.cs.StreamEncoder.implFlushBuffer(StreamEncoder.java:272)
at sun.nio.cs.StreamEncoder.flushBuffer(StreamEncoder.java:85)
- locked <0x0000000023fb31a0> (a java.io.OutputStreamWriter)
at java.io.OutputStreamWriter.flushBuffer(OutputStreamWriter.java:168)
at java.io.PrintStream.write(PrintStream.java:477)
- locked <0x0000000023fb10f0> (a java.io.PrintStream)
at java.io.PrintStream.print(PrintStream.java:619)
at java.io.PrintStream.println(PrintStream.java:756)
- locked <0x0000000023fb10f0> (a java.io.PrintStream)
at org.datanucleus.jdo.query.JDOQueryProcessor.processClass(JDOQueryProcessor.java:159)
at org.datanucleus.jdo.query.JDOQueryProcessor.process(JDOQueryProcessor.java:135)
at com.sun.tools.javac.processing.JavacProcessingEnvironment.callProcessor(JavacProcessingEnvironment.java:625)
at com.sun.tools.javac.processing.JavacProcessingEnvironment.discoverAndRunProcs(JavacProcessingEnvironment.java:554)
at com.sun.tools.javac.processing.JavacProcessingEnvironment.doProcessing(JavacProcessingEnvironment.java:699)
at com.sun.tools.javac.main.JavaCompiler.processAnnotations(JavaCompiler.java:981)
at com.sun.tools.javac.main.JavaCompiler.compile(JavaCompiler.java:727)
at com.sun.tools.javac.main.Main.compile(Main.java:353)
at com.sun.tools.javac.main.Main.compile(Main.java:279)
at com.sun.tools.javac.main.Main.compile(Main.java:270)
at com.sun.tools.javac.Main.compile(Main.java:69)
at com.sun.tools.javac.Main.main(Main.java:54)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)


Sort Order: Ascending order - Click to sort in descending order
Andy Jefferson added a comment - 26/Aug/11 02:52 PM
No way to reproduce so downgrade to Incomplete, as per the docs. Bears no resemblance to enhancement annotation processor which had a wait() command in it

Stephane Passignat added a comment - 26/Aug/11 02:54 PM
What do you need to investigate ?

Stephane Passignat added a comment - 26/Aug/11 03:22 PM
I disable the annotation processor (-proc:none) but I don't know if it's a pb for datanucleus not having the generated classes. I'm not yet fully aware of JDOQuery classes, just understand the concept but didn't knwo the impact at runtime.

The very few test I've done shows there are no pb.

Andy Jefferson added a comment - 27/Mar/12 03:05 PM
What needed to investigate ? How about a testcase that reproduces it ? like some simple classes to compile, and when the preprocessor is invoked see what happens. And if that doesn't hang in other environments then the problem is in your env.