DataNucleus JIRA is now in read-only mode. Raise any new issues in GitHub against the plugin that it applies to. DataNucleus JIRA will remain for the foreseeable future but will eventually be discontinued
Issue Details (XML | Word | Printable)

Key: NUCJDOQUERY-9
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Unassigned
Reporter: Richard DiCroce
Votes: 0
Watchers: 2
Operations

If you were logged in you would be able to see more operations.
DataNucleus JDO Query Processor

Annotation processor chokes on arrays

Created: 18/Jun/11 05:13 PM   Updated: 06/Jul/12 09:43 AM   Resolved: 18/Jun/11 08:06 PM
Component/s: None
Affects Version/s: 3.0.0.m2
Fix Version/s: 3.0.0.m3

File Attachments: 1. Zip Archive ArrayTestCase.zip (0.3 kB)



 Description  « Hide
The JDO Query annotation processor chokes if it encounters a @PersistenceCapable class that contains an array. It throws the following exception:

java.lang.NullPointerException
at org.datanucleus.jdo.query.JDOQueryProcessor.isJDOAnnotated(JDOQueryProcessor.java:670)
at org.datanucleus.jdo.query.JDOQueryProcessor.getExpressionInterfaceNameForType(JDOQueryProcessor.java:487)
at org.datanucleus.jdo.query.JDOQueryProcessor.processClass(JDOQueryProcessor.java:251)
at org.datanucleus.jdo.query.JDOQueryProcessor.process(JDOQueryProcessor.java:135)

Richard DiCroce added a comment - 18/Jun/11 05:16 PM
Test case for the bug.

Richard DiCroce made changes - 18/Jun/11 05:16 PM
Field Original Value New Value
Attachment ArrayTestCase.zip [ 11454 ]
Andy Jefferson added a comment - 18/Jun/11 08:06 PM
SVN trunk works on arrays

Andy Jefferson made changes - 18/Jun/11 08:06 PM
Status Open [ 1 ] Resolved [ 5 ]
Fix Version/s 3.0.0.m3 [ 11269 ]
Resolution Fixed [ 1 ]
Stephane Passignat added a comment - 25/Aug/11 04:28 PM
I encounter the same Issue with 3.0.0 m5.
Where is it fixed?
any solution to bypass ?

Stephane Passignat added a comment - 25/Aug/11 04:30 PM
With an array of int or String.

Andy Jefferson added a comment - 26/Aug/11 12:13 AM
Where is it fixed ? click on Subversion Commits.
What is it fixed on ? the testcase that was provided.

Richard DiCroce added a comment - 26/Aug/11 01:11 AM
@Stephane: Update to 3.0 final. For me, the problem is resolved.

Andy Jefferson made changes - 06/Jul/12 09:43 AM
Status Resolved [ 5 ] Closed [ 6 ]