DataNucleus JIRA is now in read-only mode. Raise any new issues in GitHub against the plugin that it applies to. DataNucleus JIRA will remain for the foreseeable future but will eventually be discontinued
Issue Details (XML | Word | Printable)

Key: NUCJPA-229
Type: Bug Bug
Status: Closed Closed
Resolution: Cannot Reproduce
Priority: Testcase Required Testcase Required
Assignee: Unassigned
Reporter: subes
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
DataNucleus API JPA

javax.jdo.JDOUserException: Cannot share owned second-class objects

Created: 14/Apr/13 12:40 PM   Updated: 14/Apr/13 01:49 PM   Resolved: 14/Apr/13 01:48 PM
Component/s: None
Affects Version/s: 3.2.1
Fix Version/s: None


 Description  « Hide
Most of my test cases become red when upgrading to Datanucleus 3.2.2 and all other libraries to their latest versions.
Any idea where this exception comes from?

{quote}
javax.jdo.JDOUserException: Cannot share owned second-class objects, object owned by field created of object TestEntity[name:testMultiplePersistenceUnitsWork|id:0|version:<null>|created:Sonntag, 14. April 2013 12:34:56 MESZ|updated:<null>|jdoDetachedState:<null>]
at org.datanucleus.state.JDOStateManager.setObjectField(JDOStateManager.java:1934)
at de.invesdwin.common.persistence.api.AEntity.jdoSetupdated(AEntity.java)
at de.invesdwin.common.persistence.api.AEntity.setCreated(AEntity.java:78)
at de.invesdwin.common.persistence.api.AEntity.prePersist(AEntity.java:123)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:601)
at org.datanucleus.api.jpa.JPACallbackHandler$1.run(JPACallbackHandler.java:410)
at java.security.AccessController.doPrivileged(Native Method)
at org.datanucleus.api.jpa.JPACallbackHandler.invokeCallbackMethod(JPACallbackHandler.java:398)
at org.datanucleus.api.jpa.JPACallbackHandler.invokeCallback(JPACallbackHandler.java:351)
at org.datanucleus.api.jpa.JPACallbackHandler.prePersist(JPACallbackHandler.java:82)
at org.datanucleus.state.JDOStateManager.makePersistent(JDOStateManager.java:3704)
at org.datanucleus.ExecutionContextImpl.persistObjectInternal(ExecutionContextImpl.java:2124)
at org.datanucleus.ExecutionContextImpl.persistObjectWork(ExecutionContextImpl.java:1972)
at org.datanucleus.ExecutionContextImpl.persistObject(ExecutionContextImpl.java:1820)
at org.datanucleus.api.jpa.JPAEntityManager.persist(JPAEntityManager.java:567)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:601)
at org.springframework.orm.jpa.SharedEntityManagerCreator$SharedEntityManagerInvocationHandler.invoke(SharedEntityManagerCreator.java:241)
at sun.proxy.$Proxy58.persist(Unknown Source)
at org.springframework.data.jpa.repository.support.SimpleJpaRepository.save(SimpleJpaRepository.java:350)
at de.invesdwin.common.persistence.api.ADao.save_aroundBody30(ADao.java:177)
at de.invesdwin.common.persistence.api.ADao$AjcClosure31.run(ADao.java:1)
at org.springframework.transaction.aspectj.AbstractTransactionAspect.ajc$around$org_springframework_transaction_aspectj_AbstractTransactionAspect$1$2a73e96cproceed(AbstractTransactionAspect.aj:59)
at org.springframework.transaction.aspectj.AbstractTransactionAspect$AbstractTransactionAspect$1.proceedWithInvocation(AbstractTransactionAspect.aj:65)
at org.springframework.transaction.interceptor.TransactionAspectSupport.invokeWithinTransaction(TransactionAspectSupport.java:260)
at org.springframework.transaction.aspectj.AbstractTransactionAspect.ajc$around$org_springframework_transaction_aspectj_AbstractTransactionAspect$1$2a73e96c(AbstractTransactionAspect.aj:63)
at de.invesdwin.common.persistence.api.ADao.save(ADao.java:176)
at de.invesdwin.common.persistence.datanucleus.MultiplePersistenceUnitsTest.testMultiplePersistenceUnitsWork(MultiplePersistenceUnitsTest.java:24)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:601)
at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:47)
at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:44)
at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:17)
at org.junit.internal.runners.statements.RunBefores.evaluate(RunBefores.java:26)
at org.springframework.test.context.junit4.statements.RunBeforeTestMethodCallbacks.evaluate(RunBeforeTestMethodCallbacks.java:74)
at org.junit.internal.runners.statements.RunAfters.evaluate(RunAfters.java:27)
at org.springframework.test.context.junit4.statements.RunAfterTestMethodCallbacks.evaluate(RunAfterTestMethodCallbacks.java:83)
at org.springframework.test.context.junit4.statements.SpringRepeat.evaluate(SpringRepeat.java:72)
at org.springframework.test.context.junit4.SpringJUnit4ClassRunner.runChild(SpringJUnit4ClassRunner.java:231)
at org.springframework.test.context.junit4.SpringJUnit4ClassRunner.runChild(SpringJUnit4ClassRunner.java:88)
at org.junit.runners.ParentRunner$3.run(ParentRunner.java:238)
at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:63)
at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:236)
at org.junit.runners.ParentRunner.access$000(ParentRunner.java:53)
at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:229)
at org.springframework.test.context.junit4.statements.RunBeforeTestClassCallbacks.evaluate(RunBeforeTestClassCallbacks.java:61)
at org.junit.internal.runners.statements.RunAfters.evaluate(RunAfters.java:27)
at org.springframework.test.context.junit4.statements.RunAfterTestClassCallbacks.evaluate(RunAfterTestClassCallbacks.java:71)
at org.junit.runners.ParentRunner.run(ParentRunner.java:309)
at org.springframework.test.context.junit4.SpringJUnit4ClassRunner.run(SpringJUnit4ClassRunner.java:174)
at org.junit.runners.Suite.runChild(Suite.java:127)
at org.junit.runners.Suite.runChild(Suite.java:26)
at org.junit.runners.ParentRunner$3.run(ParentRunner.java:238)
at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:63)
at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:236)
at org.junit.runners.ParentRunner.access$000(ParentRunner.java:53)
at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:229)
at org.junit.runners.ParentRunner.run(ParentRunner.java:309)
at org.eclipse.jdt.internal.junit4.runner.JUnit4TestReference.run(JUnit4TestReference.java:50)
at org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:467)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:683)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:390)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:197)
{quote}


Andy Jefferson added a comment - 14/Apr/13 12:51 PM
No testcase. No crystal ball

Andy Jefferson made changes - 14/Apr/13 12:51 PM
Field Original Value New Value
Priority Major [ 3 ] Incomplete [ 6 ]
subes added a comment - 14/Apr/13 01:36 PM - edited
Ok, sorry to tell you this but I am dropping support for datanucleus in my platform and will move forward with spring-data for my NoSQL needs. Thanks for providing datanucleus up to this point. If you want you can close this issue.

Andy Jefferson made changes - 14/Apr/13 01:48 PM
Status Open [ 1 ] Closed [ 6 ]
Resolution Cannot Reproduce [ 5 ]