DataNucleus JIRA is now in read-only mode. Raise any new issues in GitHub against the plugin that it applies to. DataNucleus JIRA will remain for the foreseeable future but will eventually be discontinued
Issue Details (XML | Word | Printable)

Key: NUCJPA-276
Type: Bug Bug
Status: Closed Closed
Resolution: Cannot Reproduce
Priority: Testcase Required Testcase Required
Assignee: Unassigned
Reporter: Veerasamy Nagarajan
Votes: 0
Watchers: 1

If you were logged in you would be able to see more operations.
DataNucleus API JPA

Date comparison throws javax.persistence.PersistenceException: expected ')'

Created: 21/Jul/14 10:54 PM   Updated: 21/Aug/14 02:58 PM   Resolved: 26/Jul/14 08:00 AM
Component/s: API
Affects Version/s: None
Fix Version/s: None

Environment: Tomcat 7.x

Datastore: Oracle
Severity: Development

 Description  « Hide
I am getting the below given exception when I try to compare the date objects. javax.persistence.PersistenceException: expected ')' at character 29 in "(DN_THIS.test_date = Wed Jul 16 12:19:13 EDT 2014)

Java Code :

Path<Date> datePath = gemRequest.<Date> get(field);
pred = criteriaBuilder.equal(datePath, new Date());

Andy Jefferson added a comment - 22/Jul/14 06:48 AM
Our crystal ball isn't working right now. Consequently there is a requirement for a valid testcase as per the problem reporting guide (as stated in all docs and in JIRA).

Andy Jefferson made changes - 22/Jul/14 06:48 AM
Field Original Value New Value
Priority Major [ 3 ] No Testcase [ 6 ]
Andy Jefferson added a comment - 26/Jul/14 08:00 AM
Ok, no reply, nor testcase provided. Consequently impossible to reproduce. If you come up with a testcase you can easily enough attach it to this issue and it could be re-opened

Andy Jefferson made changes - 26/Jul/14 08:00 AM
Status Open [ 1 ] Resolved [ 5 ]
Resolution Cannot Reproduce [ 5 ]
Andy Jefferson made changes - 21/Aug/14 02:58 PM
Status Resolved [ 5 ] Closed [ 6 ]