Issue Details (XML | Word | Printable)

Key: NUCMAVEN-23
Type: Bug Bug
Status: Closed Closed
Resolution: Cannot Reproduce
Priority: No Testcase No Testcase
Assignee: Unassigned
Reporter: TJ Rothwell
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
DataNucleus Tools : Maven plugin

Does not obey JAVA_HOME

Created: 18/Sep/11 12:02 AM   Updated: 14/Jun/12 01:28 PM   Resolved: 03/Oct/11 08:26 AM
Component/s: None
Affects Version/s: 3.0.0.release
Fix Version/s: None

File Attachments: 1. Text File stacktrace.txt (3 kB)



 Description  « Hide
I expected the JRE that is running maven would execute data-nucleus.

My environment did not have java in the $PATH. So the plugin fails that java cannot be found when attempting to execute:

{{org.datanucleus:maven-datanucleus-plugin:3.0.0-release:enhance}}












Sort Order: Ascending order - Click to sort in descending order
Andy Jefferson added a comment - 19/Sep/11 09:35 AM
Why not start by actually defining your problem ?
Like, for example, what goal of the M2 plugin you are invoking with what input.

As the stack trace says, the enhancer exited with a non-null exit code, and as the log would tell you what the problem was, i'd have thought your next point of call would be to look at the log

Andy Jefferson added a comment - 03/Oct/11 08:26 AM
No problem definition so not possible to reproduce