Issue Details (XML | Word | Printable)

Key: NUCMAVEN-42
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Unassigned
Reporter: Stijn Slaets
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
DataNucleus Tools : Maven plugin

jdo-api dependency is now marked as provided but the documentation on the website does not reflect this.

Created: 28/Nov/13 11:02 AM   Updated: 05/Dec/13 12:07 PM   Resolved: 05/Dec/13 09:11 AM
Component/s: None
Affects Version/s: 3.3.0.release
Fix Version/s: None


 Description  « Hide
Previously datanucleus-maven had a runtime dependency on the correct jdo-api jar. In 3.3.0-release this was replaced with a provided jar, causing projects that don't include jdo-api in their pom to break.
A solution would be to put the scope back to runtime or to document this here http://www.datanucleus.org/products/accessplatform_3_3/jpa/enhancer.html#maven

Andy Jefferson added a comment - 05/Dec/13 09:11 AM
Docs are up to date now

Andy Jefferson made changes - 05/Dec/13 09:11 AM
Field Original Value New Value
Status Open [ 1 ] Resolved [ 5 ]
Resolution Fixed [ 1 ]
Andy Jefferson made changes - 05/Dec/13 12:07 PM
Status Resolved [ 5 ] Closed [ 6 ]