Issue Details (XML | Word | Printable)

Key: NUCMONGODB-127
Type: Improvement Improvement
Status: Closed Closed
Resolution: Cannot Reproduce
Priority: Testcase Required Testcase Required
Assignee: Unassigned
Reporter: Mukhadin Buzdov
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
DataNucleus Store MongoDB

PM.makePersistentAll() utilizes several connections in AUTO flush mode for MongoDB

Created: 25/Sep/13 10:14 PM   Updated: 22/Oct/13 11:44 AM   Resolved: 14/Oct/13 09:39 AM
Component/s: None
Affects Version/s: 3.2.0.m3
Fix Version/s: None

Environment:
Windows 8 Enterprise x64,
JDK 1.7.0_17,
MongoDB 2.2.3

Datastore: MongoDB


 Description  « Hide
PM.makePersistentAll(Collection) creates separate connection and query for each entity in Collection, but not use only one query instead.
This happen for MongoDB only in AUTO flush mode, setting flush mode to MANUAL can "fix" it.
Suggestion is to use only one query in both flush modes.


Just for information:
Same thing happen also with RDBMS (PostgreSQL 8.4) for both flush modes: MANUAL and AUTO.
Kind of workaround for this is to use statements batch with 'datanucleus.nontx.atomic=false'.
So here we have same problem.

Andy Jefferson made changes - 26/Sep/13 08:29 PM
Field Original Value New Value
Priority Minor [ 4 ] No Testcase [ 6 ]
Andy Jefferson made changes - 09/Oct/13 12:13 PM
Project DataNucleus API JDO [ 10300 ] DataNucleus Store MongoDB [ 10310 ]
Key NUCAPIJDO-60 NUCMONGODB-127
Affects Version/s 3.2.0.m3 [ 11841 ]
Affects Version/s 3.2.0.m3 [ 11850 ]
Andy Jefferson added a comment - 09/Oct/13 12:14 PM
No testcase, so will not be touched

Andy Jefferson added a comment - 14/Oct/13 09:39 AM
Kindly provide a testcase and then there is basis for discussion, otherwise such things remain problem of a user

Andy Jefferson made changes - 14/Oct/13 09:39 AM
Status Open [ 1 ] Resolved [ 5 ]
Resolution Cannot Reproduce [ 5 ]
Andy Jefferson made changes - 22/Oct/13 11:44 AM
Status Resolved [ 5 ] Closed [ 6 ]