Issue Details (XML | Word | Printable)

Key: NUCNEOFORJ-13
Type: Task Task
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Unassigned
Reporter: Andy Jefferson
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
DataNucleus Store Neo4j

Support persistence of primitive/wrapper/String arrays

Created: 30/Jul/12 06:54 PM   Updated: 27/Sep/12 04:00 PM   Resolved: 19/Sep/12 12:36 PM
Component/s: Persistence
Affects Version/s: None
Fix Version/s: 3.1.2


Dmitry Buzdin added a comment - 14/Sep/12 11:17 AM
At the moment if you would do something like this it works:

    @ElementCollection(targetClass = java.lang.String.class, fetch = FetchType.EAGER)
    java.lang.String[] nodes;

Lists and Sets are not handled however. Since Neo4j stores only arrays conversions from and to collections should be coded.

Andy Jefferson added a comment - 17/Sep/12 01:21 PM
No idea what your comment about Lists/Sets means, since this issue is for providing support for arrays; obviously if anyone has problems they can demonstrate them with valid testcases (against an issue for that situation, not something unrelated). In the same way, if people want to attach a patch to provide some feature then they can do so.

Dmitry Buzdin added a comment - 17/Sep/12 05:40 PM
What I am saying that Arrays are already supported in Neo4j implementation. And the example above show the working mapping for arrays. Or there is something wrong with the issue description. The feature, which is not supported is mapping of Lists and Sets. It is not a bug, since the code is not yet there. Wanted to help to build a proper backlog for this module.

Andy Jefferson added a comment - 17/Sep/12 06:00 PM
Yes, various things are not implemented (but that includes general support for arrays ... maybe one isolated case works but many others don't. A simple way of demonstrating which don't work is by running "test.jdo.general" against neo4j
mvn clean test -Pneo4j

If you find other features not yet added then raise separate issues for them, preferably mentioning which test.jdo.general test fails.

Dmitry Buzdin added a comment - 17/Sep/12 06:16 PM
Thanks, I will run the tests to check the missing features. Still getting my head around DN module structure.

Andy Jefferson added a comment - 19/Sep/12 12:36 PM
SVN trunk should support primitive/primitive-wrapper/String arrays now, as well as arrays of element types that are persistable as String (e.g URL[], Currency[])

Andy Jefferson made changes - 19/Sep/12 12:36 PM
Field Original Value New Value
Status Open [ 1 ] Resolved [ 5 ]
Fix Version/s 3.1.2 [ 11681 ]
Resolution Fixed [ 1 ]
Andy Jefferson made changes - 27/Sep/12 04:00 PM
Status Resolved [ 5 ] Closed [ 6 ]