Issue Details (XML | Word | Printable)

Key: NUCRDBMS-190
Type: Improvement Improvement
Status: Closed Closed
Resolution: Cannot Reproduce
Priority: No Testcase No Testcase
Assignee: Unassigned
Reporter: christiaan
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
DataNucleus Store RDBMS

Query fetch behaviour at Commit & NontransactionalRead

Created: 27/May/09 12:32 PM   Updated: 28/Nov/13 03:29 PM   Resolved: 27/Nov/13 03:14 PM
Component/s: None
Affects Version/s: None
Fix Version/s: None


 Description  « Hide
When setting:
NontransactionalRead=true
MultiThreaded=true

I would like to see (read) queries behave independent from commits on other threads using the same pm. This has been addressed in:
http://www.nabble.com/NonTransactionalRead---Query-Fetchplan-td19875446.html#a19875446

Andy Jefferson added a comment - 05/Jun/09 08:17 AM
So you could start the process by defining tests in http://datanucleus.svn.sourceforge.net/viewvc/datanucleus/test/accessplatform/trunk/test.jdo.datastore/src/test/org/datanucleus/tests/JDOQLBasicTest.java?revision=5748&view=markup
Once that is done then the behaviour is defined, and not reliant on interpretation of some mailing list thread

Andy Jefferson added a comment - 07/Sep/09 08:05 AM
Dependent on user definition of the problem and expected results, so downgrading

Andy Jefferson made changes - 07/Sep/09 08:05 AM
Field Original Value New Value
Priority Major [ 3 ] Minor [ 4 ]
christiaan added a comment - 11/Jun/10 09:00 AM
Can you describe what is not clear about the description. In my opinion I described it quite clearly.

Andy Jefferson added a comment - 11/Jun/10 09:21 AM
I simply asked for unit tests since they *define* behaviour expectations rather than rely on interpretation of words. Unit tests are the prerequisite for any such work being implemented anyway.

Since I have plenty of other things to be doing (i.e commercial clients work) this issue is not a priority for me, so your opportunity to push it forward is to provide unit tests. If you don't have time for that then fine, but its priority is unlikely to change without that

Andy Jefferson made changes - 25/Jun/13 01:04 PM
Priority Minor [ 4 ] No Testcase [ 6 ]
Andy Jefferson added a comment - 27/Nov/13 03:14 PM
No precise definition of the problem more than 4 years after it was raised. The link in the problem description is broken. Re-raise with a clear description and associated testcase if this is a problem

Andy Jefferson made changes - 27/Nov/13 03:14 PM
Status Open [ 1 ] Resolved [ 5 ]
Resolution Cannot Reproduce [ 5 ]
Andy Jefferson made changes - 28/Nov/13 03:29 PM
Status Resolved [ 5 ] Closed [ 6 ]