DataNucleus JIRA is now in read-only mode. Raise any new issues in GitHub against the plugin that it applies to. DataNucleus JIRA will remain for the foreseeable future but will eventually be discontinued
Issue Details (XML | Word | Printable)

Key: NUCRDBMS-208
Type: Bug Bug
Status: Closed Closed
Resolution: Cannot Reproduce
Priority: Major Major
Assignee: Unassigned
Reporter: Yang ZHONG
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
DataNucleus Store RDBMS

DB2 : sql-type="CLOB(1M)" shouldn't have been too much different from JDBC CLOB for Java String

Created: 25/Jun/09 07:49 PM   Updated: 20/Oct/10 09:30 AM   Resolved: 13/Oct/10 02:51 PM
Component/s: Types
Affects Version/s: 1.1.3
Fix Version/s: None

File Attachments: 1. Zip Archive 208.zip (2 kB)

Environment: Linux, Java 5, DB2 9.1.0.2

Datastore: IBM DB2
Severity: Production


 Description  « Hide
SQL type CLOB(1M) declared for field "org.datanucleus.test.A.c" of java type java.lang.String cant be mapped for this datastore.
org.datanucleus.exceptions.NucleusException: SQL type CLOB(1M) declared for field "org.datanucleus.test.A.c" of java type java.lang.String cant be mapped for this datastore.
        at org.datanucleus.store.rdbms.mapping.RDBMSMappingManager.getDatastoreMappingClass(RDBMSMappingManager.java:296)
        at org.datanucleus.store.rdbms.mapping.RDBMSMappingManager.createDatastoreMapping(RDBMSMappingManager.java:530)
        at org.datanucleus.store.mapped.mapping.SingleFieldMapping.prepareDatastoreMapping(SingleFieldMapping.java:57)
        at org.datanucleus.store.mapped.mapping.SingleFieldMapping.initialize(SingleFieldMapping.java:46)
        at org.datanucleus.store.mapped.mapping.MappingFactory.createMapping(MappingFactory.java:97)
        at org.datanucleus.store.mapped.mapping.AbstractMappingManager.getMapping(AbstractMappingManager.java:248)
        at org.datanucleus.store.rdbms.table.ClassTable.manageMembers(ClassTable.java:567)
        at org.datanucleus.store.rdbms.table.ClassTable.manageClass(ClassTable.java:447)
        at org.datanucleus.store.rdbms.table.ClassTable.initializeForClass(ClassTable.java:1086)
        at org.datanucleus.store.rdbms.table.ClassTable.initialize(ClassTable.java:264)
        at org.datanucleus.store.rdbms.RDBMSManager$ClassAdder.initializeClassTables(RDBMSManager.java:2642)
        at org.datanucleus.store.rdbms.RDBMSManager$ClassAdder.addClassTablesAndValidate(RDBMSManager.java:2549)
        at org.datanucleus.store.rdbms.RDBMSManager$ClassAdder.run(RDBMSManager.java:2200)
        at org.datanucleus.store.rdbms.AbstractSchemaTransaction.execute(AbstractSchemaTransaction.java:113)
        at org.datanucleus.store.rdbms.RDBMSManager.addClasses(RDBMSManager.java:992)
        at org.datanucleus.store.rdbms.SchemaTool.createSchema(SchemaTool.java:702)
        at org.datanucleus.store.rdbms.SchemaTool.main(SchemaTool.java:292)

Yang ZHONG added a comment - 25/Jun/09 07:49 PM
Can't test against 1.1.4 due to NUCRDBMS-205

Yang ZHONG made changes - 25/Jun/09 07:49 PM
Field Original Value New Value
Attachment 208.zip [ 10965 ]
Yang ZHONG added a comment - 25/Jun/09 07:52 PM
sql-type="CLOB(1024)" throws the same Exception.

Andy Jefferson made changes - 10/Dec/09 11:13 AM
Summary sql-type="CLOB(1M)" shouldn't have been too much different from JDBC CLOB for Java String DB2 : sql-type="CLOB(1M)" shouldn't have been too much different from JDBC CLOB for Java String
Andy Jefferson added a comment - 13/Oct/10 02:51 PM
DN interpretation of "sql-type" is that it is the ***type*** and not the type+size. The "length"/"precision"/"scale" are best used for the length of a type. Consequently you can set "sql-type" and "length" and get CLOB(1024), at least with SVN code

Andy Jefferson made changes - 13/Oct/10 02:51 PM
Status Open [ 1 ] Resolved [ 5 ]
Resolution Cannot Reproduce [ 5 ]
Andy Jefferson made changes - 20/Oct/10 09:30 AM
Status Resolved [ 5 ] Closed [ 6 ]