DataNucleus JIRA is now in read-only mode. Raise any new issues in GitHub against the plugin that it applies to. DataNucleus JIRA will remain for the foreseeable future but will eventually be discontinued
Issue Details (XML | Word | Printable)

Key: NUCRDBMS-427
Type: Bug Bug
Status: Closed Closed
Resolution: Cannot Reproduce
Priority: Major Major
Assignee: Unassigned
Reporter: Alexander Ley
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
DataNucleus Store RDBMS

Wrong: OracleAdapter only supports boolean char expressions

Created: 01/Jul/10 04:13 PM   Updated: 20/Oct/10 09:30 AM   Resolved: 21/Sep/10 01:43 PM
Component/s: Queries
Affects Version/s: 2.1.1
Fix Version/s: None

File Attachments: 1. Zip Archive NUCRDBMS-427_testcase.zip (1 kB)

Environment: Oracle 10g

Forum Thread URL: http://www.datanucleus.org/servlet/forum/viewthread_thread,6192
Datastore: Oracle


 Description  « Hide
"ORDER BY boolean" leads to Exception
org.datanucleus.exceptions.NucleusException: OracleAdapter only supports boolean char expressions
        at org.datanucleus.store.rdbms.adapter.OracleAdapter.getOrderString(OracleAdapter.java:647)
        at org.datanucleus.store.rdbms.sql.SQLStatement.generateOrderingStatement(SQLStatement.java:1927)
        at org.datanucleus.store.rdbms.sql.SQLStatement.getSelectStatement(SQLStatement.java:1604)
        at org.datanucleus.store.rdbms.query.JDOQLQuery.compileQueryFull(JDOQLQuery.java:883)
        at org.datanucleus.store.rdbms.query.JDOQLQuery.compileInternal(JDOQLQuery.java:294)
        at org.datanucleus.store.query.Query.executeQuery(Query.java:1642)
        at org.datanucleus.store.query.Query.executeWithMap(Query.java:1540)
        at org.datanucleus.jdo.JDOQuery.executeWithMap(JDOQuery.java:334)
        at de.isys.lvs.domain.util.JDOQueryDefinition$1.doInJdo(JDOQueryDefinition.java:637)
        at org.springframework.orm.jdo.JdoTemplate.execute(JdoTemplate.java:260)

Alexander Ley added a comment - 01/Jul/10 04:16 PM
Testcase

Alexander Ley made changes - 01/Jul/10 04:16 PM
Field Original Value New Value
Attachment NUCRDBMS-427_testcase.zip [ 11222 ]
Alexander Ley added a comment - 12/Jul/10 12:40 PM
This could perhaps be related to NUCRDBMS-430

Andy Jefferson added a comment - 21/Sep/10 01:43 PM
I have no issue running that testcase

Andy Jefferson made changes - 21/Sep/10 01:43 PM
Status Open [ 1 ] Resolved [ 5 ]
Resolution Cannot Reproduce [ 5 ]
Alexander Ley added a comment - 22/Sep/10 11:49 AM
Running the test case on my system work fine now too. Seems that some change has fixed this.

Andy Jefferson made changes - 20/Oct/10 09:30 AM
Status Resolved [ 5 ] Closed [ 6 ]