DataNucleus JIRA is now in read-only mode. Raise any new issues in GitHub against the plugin that it applies to. DataNucleus JIRA will remain for the foreseeable future but will eventually be discontinued
Issue Details (XML | Word | Printable)

Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Andy Jefferson
Reporter: Andy Jefferson
Votes: 0
Watchers: 0

If you were logged in you would be able to see more operations.
DataNucleus Store RDBMS

Only currently make use of single SQL type for a JDBC type, but should allow a selection

Created: 30/Dec/11 09:30 AM   Updated: 11/Jan/12 05:28 PM   Resolved: 30/Dec/11 09:44 AM
Component/s: Schema
Affects Version/s: 2.1.4, 2.2.4, 3.0.0.release, 3.0.1, 3.0.2, 3.0.3, 3.0.4
Fix Version/s: 3.0.5

 Description  « Hide
We currently allow specification (in plugin.xml) of multiple possible sql-type for a jdbc-type, and the internal storage allows this too. The problem is that the RDBMSMappings only use the default SQLTypeInfo, hence any schema generation will ignore the user-specified sql-type

Andy Jefferson added a comment - 30/Dec/11 09:44 AM
SVN trunk fixes this, so can make use of all defined sql-type values in plugin.xml for schema generation

Andy Jefferson made changes - 30/Dec/11 09:44 AM
Field Original Value New Value
Status Open [ 1 ] Resolved [ 5 ]
Assignee Andy Jefferson [ andy ]
Resolution Fixed [ 1 ]
Andy Jefferson made changes - 11/Jan/12 05:28 PM
Status Resolved [ 5 ] Closed [ 6 ]