Issue Details (XML | Word | Printable)

Key: NUCRDBMS-605
Type: Bug Bug
Status: Closed Closed
Resolution: Cannot Reproduce
Priority: Testcase Required Testcase Required
Assignee: Unassigned
Reporter: Jamie Bolat
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
DataNucleus Store RDBMS

create schema tool not creating tablenames according to case in the .orm file

Created: 31/Jul/12 04:15 PM   Updated: 27/Sep/12 04:00 PM   Resolved: 24/Sep/12 08:11 PM
Component/s: ORM
Affects Version/s: 3.1.0.m5, 3.1.0.release
Fix Version/s: None

Environment: Windows 7

Forum Thread URL: http://www.datanucleus.org/servlet/forum/viewthread_thread,7225
Datastore: MySQL
Severity: Production


 Description  « Hide
Hi have generated my database schema via the createschema tool in Windows 7. Even though in the .orm file the database tablenames were written in upper case, the generator created the MySQL schema tables in lowercase. The problem with this is that when deploying to Unix, the tablename are case-sensitive. So, even though the tablenames case does not matter in Windows, it does in Unix. The twist to this bug is that if you use the createschema directly in Unix (in my case tested on Unix Lunix Ubuntu), then it does actually create the tablenames as in the .orm file, that is, in capitals.

Andy Jefferson added a comment - 04/Aug/12 03:45 PM
As per the front page of JIRA, and all of the docs, any "issue" has to have a valid testcase attached that demonstrates it as per
http://www.datanucleus.org/project/problem_jdo_testcase.html

Anything that doesn't have such a testcase will not be touched; you can easily get the code and contribute fixes.

Andy Jefferson made changes - 04/Aug/12 03:45 PM
Field Original Value New Value
Priority Minor [ 4 ] Incomplete [ 6 ]
Andy Jefferson added a comment - 24/Sep/12 08:11 PM
No testcase provided so closing since can't reproduce something that has no way of seeing the "problem". Obviously, at some point, you could attach a valid testcase as per the Problem Reporting doc and this can be reopened.

Andy Jefferson made changes - 24/Sep/12 08:11 PM
Status Open [ 1 ] Resolved [ 5 ]
Resolution Cannot Reproduce [ 5 ]
Andy Jefferson made changes - 27/Sep/12 04:00 PM
Status Resolved [ 5 ] Closed [ 6 ]