Issue Details (XML | Word | Printable)

Key: NUCRDBMS-609
Type: Bug Bug
Status: Closed Closed
Resolution: Cannot Reproduce
Priority: No Testcase No Testcase
Assignee: Unassigned
Reporter: Dan Haywood
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
DataNucleus Store RDBMS

DataNucleus extension for exposing the version as a property does not work properly.

Created: 16/Aug/12 07:15 PM   Updated: 28/Aug/12 09:55 AM   Resolved: 27/Aug/12 03:23 PM
Component/s: None
Affects Version/s: 3.1.0.release
Fix Version/s: None

File Attachments: 1. Zip Archive test.zip (4 kB)


Forum Thread URL: http://www.datanucleus.org/servlet/forum/viewthread_thread,7243_lastpage,yes#36003
Severity: Development


 Description  « Hide
As per forum thread below.

reproduce using:


@Version(strategy=VersionStrategy.VERSION_NUMBER, column="VERSION"
         ,extensions={@Extension(vendorName="datanucleus", key="field-name", value="version")}
                )
public class Foo {
    // fieldA
    // fieldB
    // fieldC
   
    // {{ Version (property)
    private long version;

    @Disabled
    @MemberOrder(sequence = "3")
    public long getVersion() {
        return version;
    }

    public void setVersion(final long version) {
        this.version = version;
    }
    // }}

}

do an update of Foo's fieldA and fieldB; then of just fieldC, then of fieldA and fieldB again; get a mismatch because update of Version property is skipped, messing up setParameter index numbers.

Andy Jefferson added a comment - 16/Aug/12 07:31 PM
Attached test case does what you describe, and it works for me. So please update it and reattach a test that demonstrates the problem

Andy Jefferson made changes - 16/Aug/12 07:31 PM
Field Original Value New Value
Attachment test.zip [ 11712 ]
Andy Jefferson made changes - 18/Aug/12 10:49 AM
Priority Major [ 3 ] Incomplete [ 6 ]
Dan Haywood added a comment - 21/Aug/12 08:38 AM
Hmm, it does seem to work here. Tried changing your test class into the very same that I'm working on, but no joy either.

Oh well, I'm working around the problem for my own code.

Andy Jefferson made changes - 27/Aug/12 03:23 PM
Status Open [ 1 ] Resolved [ 5 ]
Resolution Cannot Reproduce [ 5 ]
Andy Jefferson made changes - 28/Aug/12 09:55 AM
Status Resolved [ 5 ] Closed [ 6 ]