Issue Details (XML | Word | Printable)

Key: NUCRDBMS-665
Type: Bug Bug
Status: Closed Closed
Resolution: Cannot Reproduce
Priority: Testcase Required Testcase Required
Assignee: Unassigned
Reporter: Boris B.
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
DataNucleus Store RDBMS

DN fails to detect the existence of a SEQUENCE_TABLE and tries to recreate it

Created: 10/Apr/13 02:33 PM   Updated: 25/Oct/13 12:28 PM   Resolved: 23/Oct/13 04:57 PM
Component/s: Schema
Affects Version/s: 3.2.1
Fix Version/s: None

Environment: Win7 x64, Java 1.6, DN 3.2.1

Datastore: Microsoft SQL Server
Severity: Development


 Description  « Hide
On Microsoft SQL Server 2008R2 using AccessPlatform 3.2.1 the existence of a sequence table is checked by issuing "sp_tables 'SEQUENCE_TABLE', '', 'databaseName'", but it should be "sp_tables 'SEQUENCE_TABLE', NULL, 'databaseName'". The former doesn't find a sequence table because the schema name is wrong (empty string instead of a NULL or a proper schema name).

This causes DN to try to create a table with CREATE TABLE databaseName..SEQUENCE_TABLE (note the '..', SQL server allows it and uses default schema for the current user), which fails if the table already exists. Also the creation of a sequence seems unaffected by the DN property AutoCreateSchema so it's a showstopper.

Sort Order: Ascending order - Click to sort in descending order
Andy Jefferson added a comment - 10/Apr/13 02:35 PM - edited
No testcase. Heck you could just provide a patch to store.rdbms plugin. Awaiting your contribution. Also define whether this was caused by the patch that someone contributed on NUCRDBMS-655 so then you can narrow your fix down to what they changed

Andy Jefferson added a comment - 23/Oct/13 04:57 PM
Since there is still no way of seeing this despite the requirement for providing a testcase and being asked to provide one, has to be marked as not reproduceable. Note that http://www.datanucleus.org/servlet/jira/browse/NUCRDBMS-692 relates to SQLServer and something around the schema name. Perhaps this is the same. Only the reporter can check that since they are the only person who know what this "issue" is