DataNucleus JIRA is now in read-only mode. Raise any new issues in GitHub against the plugin that it applies to. DataNucleus JIRA will remain for the foreseeable future but will eventually be discontinued
Issue Details (XML | Word | Printable)

Type: Bug Bug
Status: Closed Closed
Resolution: Cannot Reproduce
Priority: Testcase Required Testcase Required
Assignee: Unassigned
Reporter: Andreas Göbel
Votes: 0
Watchers: 0

If you were logged in you would be able to see more operations.
DataNucleus Store RDBMS

Access to MetaDataManager hash map causes infinite loop

Created: 01/Oct/13 05:42 PM   Updated: 19/Nov/13 10:28 AM   Resolved: 18/Nov/13 05:24 PM
Component/s: None
Affects Version/s: 3.2.6
Fix Version/s: None

Datastore: MySQL
Severity: Production

 Description  « Hide
We discovered that multiple Threads looping in the provideSubclassesForClass-Method:


That create a massive performance problem.

That sounds for us like the same problem as this ticket:

Because the Map is also only a HashMap not a ConcurrentHashMap.

Andy Jefferson added a comment - 03/Oct/13 03:32 AM
No demonstration of any problem, despite all guides and JIRA entry asking for testcases for any "bug"

Andy Jefferson made changes - 03/Oct/13 03:32 AM
Field Original Value New Value
Priority Major [ 3 ] No Testcase [ 6 ]
Andy Jefferson added a comment - 18/Nov/13 05:24 PM
No testcase provided, and not a use case I have, so nothing to do. Clearly if people see this as important to them they could a). create a testcase that people can run, and b). get involved in the project and contribute updates to whatever they are seeing

Andy Jefferson made changes - 18/Nov/13 05:24 PM
Status Open [ 1 ] Resolved [ 5 ]
Resolution Cannot Reproduce [ 5 ]
Andy Jefferson made changes - 19/Nov/13 10:28 AM
Status Resolved [ 5 ] Closed [ 6 ]