Issue Details (XML | Word | Printable)

Key: NUCRDBMS-767
Type: Improvement Improvement
Status: Closed Closed
Resolution: Fixed
Priority: Minor Minor
Assignee: Unassigned
Reporter: Stijn Slaets
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
DataNucleus Store RDBMS

OSGi manifest should also include new HSQLDB (v2.0+) driver import

Created: 28/Feb/14 01:52 PM   Updated: 01/Mar/14 07:39 PM   Resolved: 28/Feb/14 03:48 PM
Component/s: None
Affects Version/s: 3.2.11
Fix Version/s: 4.0.0.m1

Environment: Linux

Datastore: HSQL


 Description  « Hide
The MANIFEST.MF file contains an optional import for org.hsqldb, however HSQLDB changed the location of its driver class to org.hsqldb.jdbc

Andy Jefferson added a comment - 28/Feb/14 02:07 PM
Obviously it includes the old HSQLDB location since DataNucleus supports old versions of HSQLDB (and people use them). Perhaps you mean this issue as add support for the new version(s). In which case attach a patch or pull request with the update

Andy Jefferson made changes - 28/Feb/14 03:19 PM
Field Original Value New Value
Issue Type Bug [ 1 ] Improvement [ 4 ]
Priority Major [ 3 ] Minor [ 4 ]
Stijn Slaets added a comment - 28/Feb/14 03:37 PM

Andy Jefferson added a comment - 28/Feb/14 03:48 PM
Pull request merged into GitHub master

Andy Jefferson made changes - 28/Feb/14 03:48 PM
Status Open [ 1 ] Resolved [ 5 ]
Fix Version/s 4.0.0.m1 [ 12094 ]
Resolution Fixed [ 1 ]
Andy Jefferson made changes - 01/Mar/14 07:28 PM
Summary OSGi manifest contains old HSQLD driver import OSGi manifest should also include new HSQLDB (v2.0+) driver import
Andy Jefferson made changes - 01/Mar/14 07:39 PM
Status Resolved [ 5 ] Closed [ 6 ]