AccessPlatform : Dependencies

DataNucleus AccessPlatform utilises some third party software to provide some of its functionality. Dependent on how you intend to use this product you may have to also download some of these third party software packages. You can see below the dependencies and when they are required.

Software Description Version Requirement
Essential Dependencies
JDO API JDO API definition, developed by Apache JDO. 3.0 or later Required if you are using the JDO API or JDO Annotations. Use v3.1-rc1 or 3.0.1 depending on whether you require JDO 3.1 or JDO 3.0
JPA API JPA API definition 2.1.0 Required if you are using the JPA API or JPA annotations. Note that the JPA "Expert Group" are seemingly too lazy to upload this into a freely downloadable location so you have to use this one we prepared ourselves.
Datastore Dependencies (choose your datastore driver)
NeoDatis NeoDatis object database 1.9.30 Required if you are using a NeoDatis datastore
jaxb-api JAXB API 2.1 Required is you are using an XML datastore
jaxb-impl JAXB Reference Implementation 2.x Required if you are using an XML datastore
JDBC Driver JDBC Driver for your chosen RDBMS Required if you want to use an RDBMS datastore. Obtain from your RDBMS vendor
Apache POI Apache library for writing to Microsoft documents 3.5+ Required if you want to use Excel (XLS/OOXML) documents
ODFDOM ODF Toolkit for Java 0.8.7 Required if you want to use an ODF document for persistence.
Xerces Xerces XML parser 2.8+ Required if you want to use an ODF document for persistence. Required by ODFDOM
Apache HBase HBase 0.94+ Required if you want to persist to HBase datastores
HADOOP Core HADOOP Core 1.0+ Required if you want to persist to HBase datastores
Apache ZooKeeper Apache Zookeeper 3.4+ Required if you want to persist to HBase datastores
MongoDB Java driver MongoDB Java driver 2.4+ Required if you want to persist to MongoDB datastores
Neo4j driver Neo4j driver 1.9.4 Required if you want to persist to Neo4j datastores
Feature Dependencies (optional depending on what you want to use)
Log4j Log4J logging library. 1.2+ Required if you wish to log using Log4J. DataNucleus supports Log4J or JDK1.4 logging
mx4j MX4J management library 3.0+ Required if you want to use JMX with DataNucleus via MX4J
mx4j-tools MX4J tools 1.2+ Required if you want to use JMX with DataNucleus via MX4J
JodaTime JodaTime 1.6+ Required if you want to persist JodaTime java types
javax.time JSR Time Library 0.6+ Required if you want to persist javax.time types
GoogleCollections GoogleCollections 1.0 Required if you want to persist Google Collections java types, or are using BoneCP connection pool for RDBMS
EHCache EHCache caching product 1.0+ Required if you want to use EHCache for level 2 caching
OSCache OSCache caching product 2.1 Required if you want to use OSCache for level 2 caching
SwarmCache SwarmCache caching product 1.0RC2 Required if you want to use SwarmCache for level 2 caching
C3P0 C3P0 RDBMS connection pooling library 0.9.0+ Required if you are using an RDBMS datastore and want to use C3P0 for connection pooling
proxool Proxool RDBMS connection pooling library 0.9.0RC3 Required if you are using an RDBMS datastore and want to use Proxool for connection pooling
commons-logging Apache commons logging library 1.0+ Required if you are using an RDBMS datastore and want to use Proxool for connection pooling
bonecp BoneCP RDBMS connection pooling library 0.6.5 Required if you are using an RDBMS datastore and want to use BoneCP for connection pooling
SLF4J SLF4J logging library 1.5.6 Required if you are using BoneCP for connection pooling
sdoapi Oracle Spatial library 1.2+ Required if you want to persist Oracle spatial types
jta JTA transaction API 1.0+ Required if you want to use JTA transactions
cache-api Cache API 0.61+ Required if you want to use javax.cache L2 caching
validation-api Bean validation API 1.0+ Required if you want to use bean validation (you also require a bean validation implementation)