This package is a work-in-progress to provide datastore-agnostic naming strategies for JDO, JPA and indeed any other API. The idea following the what we originally did with IdentifierFactory except that this is just the name component, and we pass in a SchemaComponent defining what the name is for. It will ultimately be usable with all "store" plugins, and we'll migrate the stores across to use it.